Erreurs Vmware

De $1

 

punaise1.gif

Sommaire

 

Vmware.png

VMControl error -14: Unexpected response from vmware-authd: The "/usr/lib/vmware/bin/vmware-vmx" process did not start properly

  • Message d'erreur :
Could not connect to VM /mnt/volume/datas/vmware/srv007/Other Linux 2.6.x kernel.vmx

(VMControl error -14: Unexpected response from vmware-authd: The "/usr/lib/vmware/bin/vmware-vmx" process did not start properly

Try running "/usr/lib/vmware/bin/vmware-vmx /mnt/volume/datas/vmware/srv007/Other Linux 2.6.x kernel.vmx" from the command-line on the server.)

>> Impossible de démarrer la VM.


Message d'erreur suite au déplacement de la VM sur un nouveau serveur.


Solution trouvée :

Chmod u+X /chemin/nom_de_la_VM.vmx

Error: Unable to execute "/usr/bin/vmware/vmware-uninstall.pl.

Suite à un problème d'installation des vmware-tools :

A previous installation of VMware software has been detected.
The previous installation was made by the tar installer (version 3).
Keeping the tar3 installer database format.
Error: Unable to execute "/usr/bin/vmware/vmware-uninstall.pl.
Failure
Execution aborted.


Solution trouvée :

sudo rm -R /etc/vmware-tools

Unable to build the vmmon module

Lancez

./runme.pl

Pour Francois .... ;-))

  • Enable to get the access rights of source file ./lib

 

Solution :


Passes sous Gnome !!!!!!!

;-)))))

vmcontrol error -11

Renommer les fichiers *.Writelock en *.old

Relancer la machine

Sous Vmware 2.x : Error: Cannot open VM: [Database] /Chemin/machine.vmx, The virtual machine cannot be found

Sous Vmware 2.0, suite à la commande :

vmrun -T server -h http://localhost:8222/sdk -u login -p mot de passe suspend "[Database] /Chemin/machine.vmx" soft

Vous obtenez ce message d'erreur :

Error: Cannot open VM: [Database] /Chemin/machine.vmx, The virtual machine cannot be found

Losrque vous lancez la commande :

vmrun -T server -h http://localhost:8222/sdk -u login -p mot de passe list

Vous obtenez ceci :

Total running VMs: 1

[] Chemin/machine.vmx

Il s'agit d'un problème avec votre Databse.

Supprimez la et recréez la.

Le problème devrait alors être résolut.

Unable to build the vmmon module

  • Si un message d'erreur apparaît :
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

Executez :

mv /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1libgcc_s.so.1.old
mv /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0.old
cp /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/
cp /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0/

 

Lancez

./runme.pl

 

Si la clé Vmware n'est pas acceptée :

touch /etc/vmware/ssl/rui.key
touch /etc/vmware/ssl/rui.crt

Relancez

./runme.pl


Reboot


Après l'installation de tout ça, si vous essayez de vous connecter sur l'interface web de management vmware .... ben ça marche pas !

Adresse : https://"ipduserveur":8333

Décidément !!!!


Solution :

Editez le script de lancement de httpd.vmware "/etc/init.d/httpd.vmware"

Remplacez le bloc :

 

start)
        vmware_exec "Starting httpd.vmware:" vmware_start_httpd
        ;;
  stop)
        vmware_exec  "Shutting down http.vmware: " vmware_stop_httpd
        ;;


Par :

 

start)
        if [ ! -d /var/run/vmware/httpd ]
        then
                echo "Directory: var/run/vmware/httpd Not found. Creating it."
                mkdir /var/run/vmware/httpd
                echo "Setting user and group ownership to: User: www-data, Group: nogroup"
                chown www-data:nogroup /var/run/vmware/httpd
                echo "Setting directory permissions to: RWX------ (700)"
                chmod 777 /var/run/vmware/httpd
        fi         
        echo "Starting httpd.vmware:"
        vmware_start_httpd
        ;;
  stop)
        echo "Shutting down http.vmware: "
        vmware_stop_httpd
        ;;

 

Modifiez également :

 

 if [ "$VMWARE_DEBUG" = 'yes' ]; then
     (trap  SIGHUP; "$func" "$@")
   else
     (trap  SIGHUP; "$func" "$@") >/dev/null 2>&1
   fi


Par :

 

if [ "$VMWARE_DEBUG" = 'yes' ]; then
    (trap  HUP; "$func" "$@")
  else
    (trap  HUP; "$func" "$@") >/dev/null 2>&1
  fi

 

Rebootez

 

Et là, une chance sur deux que ça ne marche toujours pas ...

Si tel est le cas :

Créez manuellement un dossier vmware puis httpd:

/var/run/vmware/httpd

Attribuez les droits 777 aux dossiers

/etc/init.d/httpd.vmware restart

Normalement ça doit fonctionner.

La touche "Alt Gr" ne fonctionne pas

Dans /etc/vmware/config

Ajouter :

xkeymap.keycode.108 = 0x138 # Alt_R
xkeymap.keycode.106 = 0x135 # KP_Divide
xkeymap.keycode.104 = 0x11c # KP_Enter
xkeymap.keycode.111 = 0x148 # Up
xkeymap.keycode.116 = 0x150 # Down
xkeymap.keycode.113 = 0x14b # Left
xkeymap.keycode.114 = 0x14d # Right
xkeymap.keycode.105 = 0x11d # Control_R
xkeymap.keycode.118 = 0x152 # Insert
xkeymap.keycode.119 = 0x153 # Delete
xkeymap.keycode.110 = 0x147 # Home
xkeymap.keycode.115 = 0x14f # End
xkeymap.keycode.112 = 0x149 # Prior
xkeymap.keycode.117 = 0x151 # Next
xkeymap.keycode.78 = 0x46 # Scroll_Lock
xkeymap.keycode.127 = 0x100 # Pause
xkeymap.keycode.133 = 0x15b # Meta_L
xkeymap.keycode.134 = 0x15c # Meta_R
xkeymap.keycode.135 = 0x15d # Menu


Redémarrer les VM.

msg.checkpoint.resume.fail

msg.checkpoint.resume.fail:Your virtual machine did not resume because of an error. 
If you believe the error is correctable and you want to preserve the suspended state 
so you can correct the error after the virtual machine is powered off, select Preserve. 
To discard the suspended state, select Discard.

Solution

Renommer tous les dossiers et fichiers *.lck et *.lck.old

Impossible de se connecter à l'interface web Vmware serveur 2

Symptomes

  • Impossible de se connecter à l'interface Web : Utilisateur non reconnu
  • Impossible de redémarrer le service vmware-mgmt


Il s'agit apparemment d'un plantage du service vmware-mgmt

Solution

Killer le process vmware-mgmt pour pouvoir le redémarrer :

  • Ouvrir une session ssh et exécuter les commandes avec les droits root

 

  • Aller dans le dossier var/run/vmware :
cd /var/run/vmware

 

  • Lancer cette commande :
ls -l vmware-hostd.PID watchdog-hostd.PID

 

  • Déterminer l'ID du process :
cat vmware-hostd.PID

Exemple :

[root@vmware]# cat vmware-hostd.PID

1191[root@vmware]#

 

  • Kill du process :
kill -9 <PID>


Exemple :

kill -9 1191 .

 

  • Supprimer les fichiers vmware-hostd.PID et watchdog-hostd.PID :
rm vmware-hostd.PID watchdog-hostd.PID

 

  • Redémarrer le service vmware-mgmt :
/etc/init.d/vmware-mgmt restart

 

Problème vu sous Ubuntu 9.04 serveur

DetailsRuntimeFault: Database temporarily unavailable or has network problems

http://kb.vmware.com/selfservice/mic...rnalId=1007662

   1.      Stop the VMware Server host agent (at the command line, enter /etc/init.d/vmware-mgmt stop) .

   2.      Create a backup copy of the /etc/vmware/hostd/authorization.xml file.

   3.      Open /etc/vmware/hostd/authorization.xml  in an editor and
set <NextAceId>  to the next integer value that is not being used
as as an <ACEDataId>.

      For example, if the file contains the entry:

      <NextAceId>11</NextAceId>

      Change it to:

      <NextAceId>12</NextAceId>

   4.      Save the updated file.

   5.      Restart the host agent (at the command line, enter /etc/init.d/vmware-mgmt start) .

 

authorization.xml par défaut(vmware server 2.0.1)

<ConfigRoot>
  <ACEData id="11">
    <ACEDataEntity>ha-folder-root</ACEDataEntity>
    <ACEDataId>11</ACEDataId>
    <ACEDataIsGroup>false</ACEDataIsGroup>
    <ACEDataPropagate>true</ACEDataPropagate>
    <ACEDataRoleId>-1</ACEDataRoleId>
    <ACEDataUser>root</ACEDataUser>
  </ACEData>
</ConfigRoot>

 

Setup is unable to find the "killall" program on your machine.

apt-get install psmisc

Cannot open the disk 'XXX' or one of the snapshot disks it depends on. reason: failed to lock the file

Supprimer les dossiers avec l'extension *.lck

Relancer la VM

 howto05_small.pngVous en pensez quoi ?


 

 

 

 
 
Images (0)
 
Commentaires (2)
Affichage de 2 commentaires sur 2: voir tout
SUUUUUUUUUPER MERCI
Posté 17:31, 11 Sep 2011
Merci pour le petit message, c'est toujours agréable.
Posté 17:40, 27 Sep 2011
Affichage de 2 commentaires sur 2: voir tout
Vous devez être connecté pour poster un commentaire.